PluginUs.Net - Business Tools for WooCommerce and WordPress

[realize your idea - make your dreams come true]

Support Forum

You need to log-in to create request (topic) to the support

Woof issue

The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.
If you not got email within 24~36 business hours, firstly check your spam box, and if no any email from the support there - back to the forum and read answer here. DO NOT ANSWER ON EMAILS [noreply@pluginus.net] FROM THE FORUM!! Emails are just for your info, all answers should be published only here.
The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.

Can not post private ticket???

Hello

To add  any private  data - https://share.stackovergo.com/image/i20210618130558.png ->https://share.stackovergo.com/image/i20210618130637.png

You can write your main question here

Hi @pavlo_borysenco. Thanks for the instructions.

 

I have now added access to my site to check why the filter is not working. It might be I set it up wrong but the following is not working:

 

  • Filtering by price
  • Filtering by weight + height
    • there is some bug that contracts the width filter to 0 everytime I change it. This is date range I have selected: https://ibb.co/dLqs8zr >>> And this is how the filter looks after updating finished: https://ibb.co/5jhHCbn
    • the opposite goes for legth. No matter what range I select, it expands to the highest value (include all). This is what I selected: https://ibb.co/ZMcdqcR >>> and this is after the filter updated: https://ibb.co/h1ChMCq
    • applying these filters also filters out all products to show"no results".

Thank you for your support.

Hello

Filtering by price - Please  disable  my plugin  and  do a  test  with  native  woocommerce price  filter

Filtering by weight + height - Have you customized the plugin code?

Hello.

 

Filtering by price - Please  disable  my plugin  and  do a  test  with  native  woocommerce price  filter
Answer: WC filter is working in the Storefront theme: https://ibb.co/pn8KDQs

Filtering by weight + height - Have you customized the plugin code?
Answer: No, I haven't.

I think it has something to do with the way it's set up. When I select"Options" >"Set filter automatically on the shop page" the filtering works. All of it - the price / width / length ranges all work - only on the /shop/ page (default store page set up in WooCommerce).

With the same setting"Set filter automatically on the shop page" and when added via Elementor - the filter is there - but price filtering is still not working. Only width/height are working.

However my desired setup is like this (that's how it's set up currently with Elementor): https://ibb.co/L8PHHck. This is not the /shop/ page though (it's the URL I sent before) and the"Set filter automatically on the shop page" setting is disabled.

 

 

 

Hello

Please  do a test

Hello,

 

I don't understand your question. I already have tested it and info is above.

Hello

I just asked to check how it works after my settings. Ok!  My test - https://c2n.me/4eIfMCc.mp4

Hi @pavlo_borysenco,

 

Ahh gotcha. I have tested it and it works now for me too. Thank you for that.

 

Can you please let me know what settings were wrong? This is a staging site and I need to reflect the same on live site.

 

Thanks again! :)

Hello

It looks like the problem is that third-party functionality on your site affects the GET request - and this breaks the search query

I made this setup - https://c2n.me/4eKRBIV.png ->https://c2n.me/4eKRG4G.png  - this setting removes GET requests and now third-party functionality cannot affect the search query

Are you sure those are the right settings? Looking at the staging site, the TURBO MODE extension is not activated. So it can't be set up. When I add it, it disables the filter.

 

https://ibb.co/ZxTdQ1B
https://ibb.co/J7Vfdp8

 

Thanks

 

 

Got it working now :) Just added the SEO as per the settings on staging site but disabled turbo and it's now working.

 

Thanks again for the support.

Hello

Yes! Sorry, the second screenshot was not correct.

Welcome;)