Support Forum

Content of the article

You need to log-in to create request (topic) to the support

WOOCS does not work with variant products and ELEX discount plugin

This support system is for all types of the plugins as for premium versions, so for free ones! If you have premium version do not forget in the private data of the request (!!not in the text of the support request!!) after its publishing insert purchase code please (see green button on the right side) and press Save button.
If you not got email within 24 business hours, firstly check your spam box, and if no any email from the support there - back to the forum and read answer here. DO NOT ANSWER ON EMAILS [noreply@pluginus.net] FROM THE FORUM!! Emails are just for your info, all answers should be published only here.
The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.

Hi

Please do this:

1)
https://enagi.com/dev/woocs/shop/enagi-personal-set/?currency=USD

2)
Add to Cart - discount price is USD 118,30

3)
Close add to cart

4)
Change to DKK . discount price is DKK 697,90

5)
Add to cart - discount price is now listed as DKK 118,30, and it should be DKK 697,90. THIS PROBLEM IS ONLY THERE ON VARIANT PRODUCTS.

Please look into this :-)

Thanks

Jesper

PRIVATE DATA

Hold your horse, the discount plugin team says it might be on their end....

Hello

To add  private  data - https://c2n.me/43pZu8Y.png

Ok, take a look at it with these two issues:

1)

No GET data in link = ON does not work.

2)

The welcome currency for any customer, or first customer should always be the geo IP currency, hwo to?

Thanks

Jesper

Hello

  1.  please paste your license key here - https://c2n.me/42HBIt7.png and  wp-admin access - https://c2n.me/42BAoj4.png
  2. https://currency-switcher.com/using-geolocation-causes-problems-doesnt-seem-to-work-for-me/

1)

Waiting for your fix...

2)

Waiting for your fix...

 

Thanks :-)

 

2)

Got error when I pasted it

( isset( $_SERVER['REMOTE_ADDR'] ) && ! empty( $_SERVER['HTTP_X_FORWARDED_FOR'] ) ) {
$_SERVER['HTTP_X_FORWARDED_FOR'] = $_SERVER['REMOTE_ADDR'];
}

 

into functions.php

Hello

1  I checked it - https://c2n.me/43vKY4D - Everything works well

2 https://c2n.me/43vKv3o.png - you entered the code incorrectly

1)

Goto https://enagi.com/dev/woocs/da/shop/ chose the Danish language.

I cannot shift between DKK and EUR and USD.

 

2)

I entered code at the button of functions.php, but still first visit is not defined by geoip setting, and advance still says Your country is not defined! Troubles with internet connection or GeoIp service. How to fix?

add_filter("woocs_geobone_ip",function(){
return true;
});

if ( isset( $_SERVER['REMOTE_ADDR'] ) && ! empty( $_SERVER['HTTP_X_FORWARDED_FOR'] ) ) {
$_SERVER['HTTP_X_FORWARDED_FOR'] = $_SERVER['REMOTE_ADDR'];
}

Hello

  1. My  test - https://c2n.me/43wYohn
  2. This means that woocommerce can not identify the location of users

ok, fixed by discount plugin :-)

 

Can close....

Hello

Ok! Great