PluginUs.Net - Business Tools for WooCommerce and WordPress

[realize your idea - make your dreams come true]

Support Forum

You need to log-in to create request (topic) to the support

Uncaught TypeError cannot show the product result number

The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.
If you not got email within 24~36 business hours, firstly check your spam box, and if no any email from the support there - back to the forum and read answer here. DO NOT ANSWER ON EMAILS [noreply@pluginus.net] FROM THE FORUM!! Emails are just for your info, all answers should be published only here.
The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.

My theme is flatsome, and I use DMTF as the Woocommerce product filter

When clicking the option, it works to filter products, but the product count is not correct, then I find the error show belew.

wp-content/plugins/meta-data-filter/ext/mdf_posts_messenger//js/posts_messenger.js

Uncaught TypeError: jQuery(...).first(...).find(...).size is not a function
at mdf_check_count_subscr (posts_messenger.js?ver=5.9.1:68:69)
at mdf_check_request_attr (posts_messenger.js?ver=5.9.1:62:9)
at mdf_init_posts_messenger (posts_messenger.js?ver=5.9.1:29:5)
at posts_messenger.js?ver=5.9.1:33:1

 

And I find the code below on your website

add_filter('mdf_terms_order',function($default){
return 'DESC';//ASC
});

//id,name,slug,count,term_group
add_filter('mdf_terms_orderby',function($default){
return 'term_group';
});

but they did not work for the attributes. Cannot adjust the term_group for any attributes.

It works on the count.

I purchased this plugin many years ago and because woocommerce have their own filters I did not use it. I tried to use it this time. but find some issues.

Also, the plugin cannot work well with perfmatters, when I wanna defer javascript, the plugin cannot work. I have to exclude from deferral: front.js, jquery.min.js, and posts_messenger.js

 

Hello

what plugin version number are you using?

Version 2.2.9

Hello

Please  delete  it  and  install  the  new  version(added  a  link to  private  data)

OR

Please drop me  wp-admin+FTP access - https://share.stackovergo.com/image/i20210618130558.png ->https://share.stackovergo.com/image/i20210618130637.png

Hi, I cannot find a new version, on codecanyon.net, the newest version is 2.2.9, and I tried to download it again, it is still 2.2.9. And your reply said added a link to private data, I can find the link.

Did you have published the new version on Codecanyon?

Hello

Please pay attention - https://share.stackovergo.com/image/i20220311092418.png

Link to the new version of the plugin in private data