PluginUs.Net - Business Tools for WooCommerce and WordPress

[realize your idea - make your dreams come true]

Support Forum

You need to log-in to create request (topic) to the support

Search by title does not work as intended

The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.
If you not got email within 24~36 business hours, firstly check your spam box, and if no any email from the support there - back to the forum and read answer here. DO NOT ANSWER ON EMAILS [noreply@pluginus.net] FROM THE FORUM!! Emails are just for your info, all answers should be published only here.
The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.

Hello!

I am encountering some difficulties with the search feature as it won't find some posts for some reason.

The search function works for both English and Greek languages, but it seems that for some reason it doesn't find the same post if I use different words in its title.

I can't explain it properly so I am attaching some images showing what is the problem:

1. Which post I want to search:

What I want

2.Works in English:

Works English

3. Works Greek:

Works Greek

4.Doesn't Work....:

Doesnt Work

 

As you can see from the images above, I am always searching for the post shown in the first image. But apparently the search display"No Data" when someone is searching with a word present in the posts title. I have also tried adding search by post_content and post_excerpt but it still doesn't work. Additionally, if I search with"EUROLIFE My Investment" it still doesn't work, but finds it if I use"EUROLIFE" or"My Investment".

Looking forward to your reply.

Hello

Please  drop  me  exact  link to the  issue

Thanks for the fast reply!

Added to private data.

Hello

My  test - https://c2n.me/4dUJdC7.png - it looks like the search works

Hmmm, I just found out why, but still can't figure out why..

If I copy paste the word from the post's title, it works. But if I write the word using the default Greek keyboard it doesn't work.

I think it has to be an encoding issue.

Try copy-pasting this: Επενδυτικού

I managed to fix this now, as I tried some tests with the title. It appears that the post was typed incorrectly somehow.

But why can't I search"EUROLIFE Επενδυτικού" without using tags, categories?

Also, can I somehow change the text encoding before initializing the search to UTF-8, ANSI etc..?

But why can't I search"EUROLIFE Επενδυτικού" without using tags, categories? - Because text search doesn't work with taxonomies

 can I somehow change the text encoding before initializing the search to UTF-8, ANSI etc..? - These are your server settings. And it must be UTF-8

But EUROLIFE is also present in the post title. It's not only a category/taxonomy.

My problem is that the search only works if I search for a specific word or words next to the word I am searching.

For example:"EUROLIFE FFH ΕΓΚΥΚΛΙΟΣ Υλικά Marketing & Επικοινωνίας του Επενδυτικού Ασφαλιστικού Προγράμματος My Investment Plan"

If I search for:

EUROLIFE FFH ΕΓΚΥΚΛΙΟΣ, it works

My Investment Plan, it works

Υλικά Marketing, it works

BUT

EUROLIFE Υλικά, doesn't work

Επενδυτικού My Investment, doesn't work

etc. etc..

Hello

Yes, because the words should be in the same order as in the title

If you need an advanced filter - https://wordpress.org/plugins/woocommerce-products-filter/

 

But I am not using woocommerce, will this search work with Posts only?

Sorry you are right.

In this case - https://wordpress.org/plugins/wp-meta-data-filter-and-taxonomy-filter/