Support Forum

Content of the article

WPBE - WordPress Posts Bulk Editor Professional
You need to log-in to create request (topic) to the support

Plugin not playing well with WP Rocket

(new from 01-07-2019)
support doesn work on saturdays and sundays, so some friday requests can be answered on monday
12

Hi,

I'm the new web developer for my client - https://www.odysseytraveller.com/ and I am having an issue with the currency switcher not switching to the correct currency on certain pages. My theory is that because we are using WP Rocket it is not playing well with the plugin.

Now I did read your documentation and it did mention activating an option to allow the currency switcher to work well with caching plugins - however even though this option is activated this does not fix the problem.

I am not sure where I should leave my credentials for you to have a look at the site - so in the interests of safety I won't be leaving them here - but if you could let me know where I should leave them that would be great (or I can just actually message the details to you directly).

To show you an example of what i mean I've created a video demonstration which you can view below:

https://cl.ly/f0ddc78afe9a

As you can see even when I change my IP address the currency doesn't change.

And yes I have selected the option to make the plugin play nice with cache plugins:

And yes I have cleared my cache after selecting that option!

So I will send you my WP Login details and if you can have a look and find out why this is happening it would be much appreciated.

Thanks a lot!

Best,
Kosta

Hello Kosta

Please paste your license key here - https://c2n.me/42HBIt7.png and  wp-admin access - https://c2n.me/42BAoj4.png

Update  plugin  to  latest  version -https://currency-switcher.com/how-to-make-auto-update-for-wordpress-plugins-and-themes-bought-on-envato/

the currency switcher not switching to the correct currency on certain pages. - Describe it in more detail! Is the currency reset or does GeoIP not work?

Hi, the Geo IP seems to work but it gets cached. I've provided purchase code and wp login in the private data. All you need to do is test with HotSpot Shield and you will see the issue.

Plugin is all ready updated to the latest version. I'm not sure exactly what you mean - the currency is cached. If the page isn't cached then the currency drop down shows correctly.

Hope that helps.

THanks

Hello

Plugin is all ready updated to the latest version. - No! Please update  plugin to latest  version! You are using a very old version .  -https://currency-switcher.com/how-to-make-auto-update-for-wordpress-plugins-and-themes-bought-on-envato/

Latest version is - 2.2.9.1

Hi,

I have done as you requested however when I get to the Plugin page of Envato Market it doesn't have the option to update the plugin - it only has the option to 'Install' the plugin. However when I try to install it I get a failure:

Honestly I feel like I'm just going to upload it manually don't get the point of doing all of this when I can just over write folder in cPanel. I will let you know if this doesn't work. If you don't hear from me - it means it's fixed :)

Also I should note when I download the Files from ThemeForest there is a folder there called !!!GIFT!!! and it contains another plugin of the same name - not sure what that is all about. A bit confusing.

 

Hi,

I've uploaded plugin manually as you can see it is showing on front end:

I've set it t play well with caching plugins:

And I've cleared the cache on WP Rocket - however after going to the front page in Australia and then turning on Hotspot shield it's locked on Australia.

Can you please investigate this issue.

Thanks

Hello

and it contains another plugin of the same name - not sure what that is all about. - No!  It's Wordpress currency switcher. for sites that do not use woocommerce

I created test page - https://www.odysseytraveller.com/test-geoip/

My test video - https://c2n.me/43gw4gJ

woocommerce incorrectly identifies the location of users

read  this please - https://currency-switcher.com/using-geolocation-causes-problems-doesnt-seem-to-work-for-me/

 

 

I don't understand - are you saying I've downloaded the wrong plugin? I'm very confused. We have WooCommerce - but you are saying your plugin is for people who do not have WooCommerce? But our site has WooCommerce right? If you could elaborate on:

'

It's Wordpress currency switcher. for sites that do not use woocommerce'

I will review the link you sent through and try to work it out - i Just want the correct country to display and the instructions to do so - so I hope that link you've provided will answer those.

Thanks

Also I have turned on HotSpot Shield to make it look like I am in America and the test page you've created still says I'm in Australia:
https://cl.ly/1177dc14be7a

Sorry - I just watched your video and I can see what you mean - let me read your instructions and let you know if this fixes the problem or not. THanks

 

Hi,

I have done the following:

  1. Set default custom location to 'Geolocate (with page caching support)
  2. Cache for logged in users on Wordpress is turned off as per instructions in linked document
  3. Note: I am using AWS hosting - is there anything that can be done there?
  4. I have added the code to my functions.php file as follows:
    if ( isset( $_SERVER['REMOTE_ADDR'] ) && ! empty( $_SERVER['HTTP_X_FORWARDED_FOR'] ) ) {
    $_SERVER['HTTP_X_FORWARDED_FOR'] = $_SERVER['REMOTE_ADDR'];
    }

None of these solutions work for me.

I have cleared the cache after doing these things however it is still showing the incorrect country. I've tested with localbrowser.com for Canada and United States and both screens are showing USD.

What else can I do?

Thanks

Do you think updating WooCommerce could be the asnwer?

https://pluginus.net/support/topic/plugin-not-playing-well-with-wp-rocket/#postid-1476

It says here they have discontinued use for some GeoIP functionality: https://wordpress.org/support/topic/geolocation-will-not-function/

Thanks

Ok I've just updated Wordpress but now the articles page isn't working and it's very slow - I'll have to revert... I'm really lost - can this work with a caching plugin? I don't want it to load a new version of the page each time someone comes to the website from a different IP. If the website is going to become slow to make this currency switcher work it defeats the whole point. Thanks

As soon as I update Wordpress to latest version it fixes the problem where the GEO doesn't work but now everything is so incredibly slow - maybe I should download to not the latest version but just the one that has the GEO working? Are you able to fix everything for me? Or just give me instructions on what I shoudl do.

Sorry I meant update WooCommerce to the latest version.

I've got an issue with my staging site as it's built on Bedrock and I'm not proficient on that - it would be really good to test all these things there - test.odysseytraveller.com - but in the mean time if you have any input. Since you have access to the backend - please check and let mek now what to do to make this plugin work.

Ok it looks like prices are now changing to USD vs AUD (I can't check with other countries as I need premium hotspot shield subscription) - not sure why the drop down at the top isn't changing but that's better than before.

Hello

are you saying I've downloaded the wrong plugin? I'm very confused - No! I described what is in the GIFT folder

Please check  options- https://c2n.me/43hGABg.png

 

 

This is activated - since you have the login to the site you can check this.

Can you give me any actionable steps to make the drop down work correctly?

Thanks

Also price is coming up double now - how do I fix this?

Best,
Kosta

12