PluginUs.Net - Business Tools for WooCommerce and WordPress

[realize your idea - make your dreams come true]
Cyber Monday 2021
Cyber Monday 2021 timer

Support Forum

You need to log-in to create request (topic) to the support

Incompatibility with Wordpress 5.6 and jQuery 3

This support system is for all types of the plugins as for premium versions, so for free ones! If you have premium version do not forget in the private data of the request (!!not in the text of the support request!!) after its publishing insert purchase code please (see blue-green button on the right side) and press Save button.
If you not got email within 24~36 business hours, firstly check your spam box, and if no any email from the support there - back to the forum and read answer here. DO NOT ANSWER ON EMAILS [noreply@pluginus.net] FROM THE FORUM!! Emails are just for your info, all answers should be published only here.
The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.

Hello, I use the latest version of your plugin 2.2.7.2.

 

After update to Wordpress 5.6 I installed recomended plugin"Enable jQuery Migrate Helper".

 

 

This plugin listed some notices for your plugin:

 

  1. jQuery.fn.bind() is deprecated => meta-data-filter/js/chosen/chosen.jquery.min.js

 

  1. jQuery.trim is deprecated; use String.prototype.trim => meta-data-filter/js/front.js

 

  1. jQuery.fn.change() event shorthand is deprecated => meta-data-filter/js/front.js

 

  1. jQuery.fn.unbind() is deprecated => meta-data-filter/js/front.js

 

  1. jQuery.fn.click() event shorthand is deprecated => meta-data-filter/js/front.js

 

  1. jQuery.fn.unbind() is deprecated => meta-data-filter/js/chosen/chosen.jquery.min.js

 

  1. jQuery.fn.bind() is deprecated => meta-data-filter/js/front.js

 

  1. jQuery.fn.keydown() event shorthand is deprecated => meta-data-filter/js/front.js

 

  1. jQuery.fn.submit() event shorthand is deprecated => meta-data-filter/js/front.js

 

 

Please, can you update your code so that your plugin is 100% compatible with Wordpress 5.6 and jQuery 3 ?

 

Thank you,

David.

Hello David.

My plugin does not have such a warning  if  you  use Wordpress 5.6  and  disable  this  third party plugin - "Enable jQuery Migrate Helper".

But we'll do research

 

Plugin"Enable jQuery Migrate Helper" is official plugin from Wordpress team that help plugin and theme developer update their code, so it is compatible with Wordpress 5.6 and jQuery 3.

So you have to install this plugin, try to use function of MDTF plugin on frontend and this plugin then list some notices to inform you what is needed to update in your plugin, to really insure that it is compatible with jQuery 3.

Hello

I will write to you as soon as we get the result