PluginUs.Net - Business Tools for WooCommerce and WordPress

[realize your idea - make your dreams come true]
Cyber Monday 2021
Cyber Monday 2021 timer

Support Forum

You need to log-in to create request (topic) to the support

forced currency not consistent in the choose payment page

This support system is for all types of the plugins as for premium versions, so for free ones! If you have premium version do not forget in the private data of the request (!!not in the text of the support request!!) after its publishing insert purchase code please (see blue-green button on the right side) and press Save button.
If you not got email within 24~36 business hours, firstly check your spam box, and if no any email from the support there - back to the forum and read answer here. DO NOT ANSWER ON EMAILS [] FROM THE FORUM!! Emails are just for your info, all answers should be published only here.
The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.

So I have an online store in Romania that will sell only in Romania so currency will be forced to national currency RON (Lei is the simbol):

But the products are imported from EU. So I like to input the product prices in EUR.

so I have this setup with euro as base currency:

I also want to show for the romanian clients the normal price in Lei but the approximate price in euro in product page and in cart and checkout pages. In order to do that I need to do two things:

1.enable the approximate switchers:

2. insert in geoip tab Romania for Euro currency:

After all this settings I have

product page ok:

cart page ok:

but payment page NOT OK:

even if I have forced the national RON currency:

Is this a BUG?


here is a link of a product to try

you have all info access in private area

(if  I remove de romania from EUR currency field in geo IP, the payment page will be in LEI and the problem is solved, but I will lose the info with approx price in euro...and I want to keep that info)


Is this a BUG?   - No!  it's  your settings - - please disable  it

Ah, thank you!!!!