PluginUs.Net - Business Tools for WooCommerce and WordPress

[realize your idea - make your dreams come true]
Cyber Monday 2021
Cyber Monday 2021 timer

Support Forum

You need to log-in to create request (topic) to the support

EURO currency showing as € 0.00, however other currencies work.

This support system is for all types of the plugins as for premium versions, so for free ones! If you have premium version do not forget in the private data of the request (!!not in the text of the support request!!) after its publishing insert purchase code please (see blue-green button on the right side) and press Save button.
If you not got email within 24~36 business hours, firstly check your spam box, and if no any email from the support there - back to the forum and read answer here. DO NOT ANSWER ON EMAILS [] FROM THE FORUM!! Emails are just for your info, all answers should be published only here.
The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.


I upgraded to the PRO version and added new currencies (CAD, NZD, GBP and Euro). Previously had only AUD and USD.

Everything is working but Euro on my test product. In the back-end it seems to be working because when I click 'Update all rates', Euro has (0.6244999766349792) next to it.

The test product page is

Also, am I able to remove"?&currency=EUR"? In a previous ticket, you suggested I re-add it in settings in order for the plugin to work.

Thank you!


My  test  -

Use  this  option -

Hi Pablo,

When I turn that on, the currencies don't change when I select from AUD > USD. When I turn"No GET data in link" off, the currencies change when selected. Is there a workaround for this?

I'm also having issues with JPY showing as ¥ 0.


Is there a workaround for this? - Check  these  options -

I'm also having issues with JPY showing as ¥ 0. - I answered you in another topic


Hi Pablo,

Thank you! I had those options turned on and the currencies don't change when I remove the"GET data" and was hoping for a workaround for this?


Unfortunately there is no workaround