Support Forum

Content of the article

You need to log-in to create request (topic) to the support

Currency issue with LiteSpeed cache

This support system is for all types of the plugins as for premium versions, so for free ones! If you have premium version do not forget in the private data of the request (!!not in the text of the support request!!) after its publishing insert purchase code please (see green button on the right side) and press Save button.
If you not got email within 24 business hours, firstly check your spam box, and if no any email from the support there - back to the forum and read answer here. DO NOT ANSWER ON EMAILS [] FROM THE FORUM!! Emails are just for your info, all answers should be published only here.
The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.

I have same problem currency jumps to the main currency on mobile view. For example Swedesh site using SEK (krona) currency, after few seconds, it’s jumps to the EUR. Our site running LiteSpeed cache and “I am using cache plugin on my site” option is enabled. On desktop version seems to be working correclty.

Topic's link.

I have using this code in function.php

add_filter(‘wp_head’, function() { $lang = get_locale(); global $WOOCS; switch ($lang) { case ‘fi_FI’: $WOOCS->set_currency(‘EUR’); break; case ‘sv_SV’: $WOOCS->set_currency(‘SEK’); break; case ‘ru_RU’: $WOOCS->set_currency(‘RUB’); break; case ‘en_GB’: $WOOCS->set_currency(‘GBP’); break; default: $WOOCS->set_currency(‘EUR’); break; } });


Please delete  your  customization and  do test.

Drop  me  exact  link  to the  issue

I have removed above code and now currency not switching automatically and there is still some issues. Cache is cleared. I'am using LiteSpeed cache.

Site URL: - english site, currency GBP - finnish site, cerrency EUR - russian site, currency RUB - sweeden, currency SEK.


Please  do  test  on this  site -

I checked it - everything seems to work correctly

video -