Support Forum

Content of the article

You need to log-in to create request (topic) to the support

Trouble creating a step by step product filter

(new from 01-07-2019)
This support system is for all types of the plugins as for premium versions, so for free ones! If you have premium version do not forget in the private data of the request (!!not in the text of the support request!!) after its publishing insert purchase code please (see green button on the right side) and press Save button.
If you not got email within 24 business hours, firstly check your spam box, and if no any email from the support there - back to the forum and read answer here. DO NOT ANSWER ON EMAILS [noreply@pluginus.net] FROM THE FORUM!! Emails are just for your info, all answers should be published only here.
The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.
12

Hello,

I've been struggeling with creating the step by step 2 filter like shown on this site:
https://demo.products-filter.com/step-by-step-filter-2/


I tried the following methods:

  • Copy pasted and modified the following shortcode(s) from the demo above and made it match my shop attributes
    • [woof_step autosubmit=0 filter_type=2 by_step="attribute_kurs, attribute_wochen, attribute_unterkunft"] [woof_products is_ajax=0 display_on_search=1]
  • Tried my own, custom shortcode
    • [woof_step filter_type=2 by_step="attribute_kurs, attribute_wochen, attribute_unterkunft"]
  • Added a "woof" in front of the "woof_step"
    • [woof woof_step filter_type=2 by_step="attribute_kurs, attribute_wochen, attribute_unterkunft"]

The problem is the following:

I am using Elementors "Shortcode" widget to display the shortcode, unfortunately it just displays the shortcode as text and doesn't load the actual shortcode. The same problem occurs when I am not using Elementor. It occurs on a regular WordPress page as well.


Here is my website-setup:

WordPress 5.3
Elementor Pro 2.7.3
WOOF Products filter 2.2.3

-> The problem also occured on WordPress 5.2.4!


Here are my questions:

  • I am using custom attributes called "Kurs", "Wochen" and "Unterkunft". Is my implementation of the attributes in the "by_step" section correct?
  • What settings do I have to choose within the product filter settings?

If you need any additional information, feel free to reply to this ticket.
Thank you very much in advance!

Hello

Please activate  this  extension - https://c2n.me/44zumS8.png

and  try  to use  this  shortcode:  [woof_step filter_type=2 by_step="pa_kurs, pa_wochen,pa_unterkunft"]

Hello Pablo,

thank you very much for your quick response.
The "by_step" still doesn't work for me. It just shows a gray box without any steps in it.

Do I have to add the attributes in /wp-admin/edit.php?post_type=product&page=product_attributes?
I added the attributes to the product itself and checked the "Use for product variants" checkbox.

Thank you very much in advance!

Hello

Do I have to add the attributes in /wp-admin/edit.php?post_type=product&page=product_attributes? - These attributes must be taxonomies. Filter does not work with text attributes

Hello Pablo,

I will check if it works later this day!

Thank you very much!

Hello

Ok!  Welcome;)

Hello Pablo,

the filter is only loading the first "by_step" (pa_sprache). It doesn't load the other steps.
My "by_step" looks like this "by_step="pa_sprache, pa_kurstyp" ".

Is there anything wrong with the by_step section?

It also doesn't show the results when I select the filters. It only shows the results after changing the settings of WOOF and then reload the page for the first time.

What am I doing wrong?

Hello

Please  drop me  exact  link  to the  issue

Hello Pablo,

the login credentials are in the private data section of this post.

I implemented the filter on the following page: <DOMAIN>/filter/

Thank you very much in advance!

Hello

Do  test  please!  reason - https://clip2net.com/s/44P8bm4

Hello Pablo,

what did you change exactly?
Did I just forget to put the comma in the shortcode?

Thanks!

It's me once again.

Can I just add more filter steps by adding more values to the shortcode?

Thank you in advance!

Hello

Not. You should enter the keys without a space

Hi Pablo,

the filters now work as expected in their respective order but they still do not show the results.
It only shows the results sometimes, when the plugin appends the parameters to the URL.

This works: https://elementabroad.com/filter/?q=1&pa_sprache=englisch&pa_kurstyp=sprachkurse-fuer-lehrer
This doesn't work: https://elementabroad.com/filter/

The plugin doesn't always append the parameters to the URL and therefor doesn't show the filter results.

Do you have any idea how we can fix it? Your account to the site is still active.

Thank you in advance!

 

Nevermind, I figured it out by myself!

Thank you very much for your support!

Hello Pablo, it's me again.

Is there a way to also use product categories or just taxonomies for filtering with the step by step filter?

Thank you in advance!

Hello

Is there a way to also use product categories or just taxonomies - Yes! the product categories is taxonomy.  Use  key - product_cat

Hello Pablo,

thank you very much for your response.
I figured out how to use the categories in the filter, however the filter doesn't display the search results anymore.

If I set "display_on_search" to 1, the seach results doesn't show up. If I set it to zero, it works as expected but I only want to show the results once the filter is applied.

I don't know what I did exactly to cause this issue. I removed all custom CSS I added to the section. Could you take another look and tell me what I did wrong?

Also, is there a way to add images in front of the taxonomies? Does the WOOF plugin support that or do I have to look for another way to implement something like this?

Thank you very much in advance!

Hello

Please  add FTP access I will check it

is there a way to add images in front of the taxonomies - Yes! Use an extension "image". Watch  video - https://products-filter.com/video-tutorials#video_beGT6p_look

Hello Pablo,

thank you for your quick reply and thank you for the tutorial, I will look into it later!
Do you need FTP access for the entire WordPress installation or just for the plugins folder?

Thank you very much!

12