PluginUs.Net - Business Tools for WooCommerce and WordPress

[realize your idea - make your dreams come true]

Support Forum

You need to log-in to create request (topic) to the support

Limitation for quick search

This support system is for all types of the plugins as for premium versions, so for free ones! If you have premium version do not forget in the private data of the request (!!not in the text of the support request!!) after its publishing insert purchase code please (see blue-green button on the right side) and press Save button.
If you not got email within 24~36 business hours, firstly check your spam box, and if no any email from the support there - back to the forum and read answer here. DO NOT ANSWER ON EMAILS [noreply@pluginus.net] FROM THE FORUM!! Emails are just for your info, all answers should be published only here.
The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.
12

Hi, thank you for best plugin.

I'm doing a product trial with a target of 83,000 products.

I see for quick search it has been tested up to 10,000 products.

Does this mean the product limit is only up to 10,000?
Or it could be more...

If it could be more, is there a definite limit to the use of this quick search.

Sincerely

Hello

Yes, use please hook 'woof_quick_search_products_limit' -> https://products-filter.com/hook/woof_quick_search_products_limit/

Hi Pablo,
Thank you for your reply.

Actually, the current product for sale is not that big.
This is for testing only.

Hello

Welcome;)

Hi,

There are a few things I want to ask.
Before that, I want to give you an additional hint.

I have a main domain and a subdomain (used as a demo site to customers)

Detailed information:
Main domain has 17 products
Subdomain A has 14,498 products
Subdomain B has 1000 products (and will continue to grow with a target of 83000)

For some reason subdomain A will be turned off / retired. Instead I create subdomain B and focus there.

The current problem is;

1. Image does not appear in the quick search feature
I just had time to double check on subdomain A (when the product had passed over 10,000).
But there is something strange that the image does not appear as it should (Please see - subdomainA). Previously this was fine as seen on subdomain B. Is this due to the increasing number of products making it difficult to display images properly? Or have I done something wrong? Please tell the problem so I don't do the same on subdomain B.

2. Prices listed do not match and this happens on all sites (please see img-Main domain, subdomainA, SubdomainB)

Case :
AKI91 The listed price is Rp.2,000,000,500,- it should be Rp.2,500,000,000,-
ASW88 The price listed is Rp.4,000,000,400,- it should be Rp.4,400,000,000,-
AWS48 The listed price is Rp.3,000,000,600,- it should be Rp.3,600,000,000,-

What is the cause and what should I do?

3. Labels (see img - labels)
Is there a setting to show labels in quick search results as seen in attachment - labels

4. The image display is not uniform. (See all attach file)
Are there any special settings to set the image display on the quick search feature so that everything looks uniform?

thank you

 

img - Main domain

img - SubdomainA

img - SubdomainB

img - add

 

Hello

Please  drop me  exact  links  to the  issue

Hi, thank you for taking your time to answer my question.

Please access here

If you need keywords for the quick search, please enter"Jakarta".

The quick search feature at show into the section"Ringkasan"

Sincerely,

Ochime

 

note : Fyi, subdomainA I have turned off/retired.

Hello Ochime

The number of products should not affect the image. Because it's just a link, it's text information.

It looks like the images on this site are working correctly.

about prices:

Do you use third-party pricing plugins?Do you have taxes set up?

Hi Pablo,

I don't use any third party pricing plugins.

The site that I built is only a place for agents who want to advertise properties.

The services stop on product page, no switching to cart, completing orders, etc.

Because the customer will contact the agent through the contact provided (I have changed the add to cart to whatsapp contact).

However, I tried to set the tax and it still doesn't change (the price shows up in quick search results).

Please help me...

Hi Pablo,

If I enter the word"Sriwijaya" in a quick search (link above) on the desktop version,it's work.

But the same thing I did on the mobile version it doesn't not work.

And then I enter the word"kemanggisan" it's work, both on the desktop and mobile versions.

Sriwijaya and kemanggisan are attribute products.

First, i do updated products on the quick search tab.

After that cleared the cache on the advance tab.

Then that clear cache (wp super cache), and lastly i updated the page where shortcode in place.

Is there a part I missed?

hi pablo,

I tried clearing the cache on the browser after reading this link and it managed to solve the last issue/question regarding the case of"sriwijaya & kemanggisan" which have different behavior.

I completely forgot about that action, sorry.

However, for the price case I have not found a solution.

Please keep helping me.

thank you

Hello

Please  drop me  ftp access - https://share.stackovergo.com/image/i20210618130558.png ->https://share.stackovergo.com/image/i20210618130637.png

I will check it

Hi Pablo,

I have sent..

please check

Hello

I cannot check now. For some reason the search file is not loaded.  Try  to re-create  it

sorry, do you mean re-create is ftp account or product data?

Hello

product data  please!

hi pablo,

I have deleted the data and reassemble the data (ext quick search) as you requested.
Please check again.

But if it still doesn't change, I have downloaded the data and uploaded it via google drive.
(Link has been saved in private data)

And not sure if this helps you or not, but let me give you a little note about what I've been doing and thinking for the last 2 days.

1. When you asked me to check related to taxes, I tried to set it but to no avail.

2. The thousands separator on the price for the main domain a set by comma, while in the subdomain set by dot, but to no avail.

3. The main domain contains 17 products, the subdomain contains 9820 products, and both give the same appearance (at the price). So, I feel think it's not of the quantity of the product.

4. I've deleted the json data (ext quick search) and tried to reassemble the data again, no change.
(this relates too to point 5)

5. Regarding"Sriwijaya & Kemanggisan", it turns out that this is not finished/still having problems.
(Sriwijaya & Kemanggisan a attribute product subdistrict)

That's right, these 2 keywords are now showing up on a quick search on both the PC and mobile versions.
However for other keywords (especially sub-districts) this gives no showing on results.
(Both on PC and mobile versions).

You can find other keywords on the code product title, sub-district and Cities. See here
The part I want you to see/check on a quick search is for the latest products.

To make sure the product is already in the database, you can also check it by taking the city name and placing it in the search field.

I've done the steps as in the previous explanation but it still doesn't work.

Please take a look at this issue too.

 

Thank you

Hello

Please  do a test

Hi pablo, it looks amazingly perfect.

Where are those settings? Because on the main domain I have to adjust the appearance as you have done.

Sorry Pablo, for other problems (Point 5) I haven't seen any changes.

Sincerely,

Ochime

Hello Ochime

Where are those settings? - Replace file please - \wp-content\plugins\woocommerce-products-filter\ext\quick_search\js\quick_search.js

Point 5 - Please describe in more detail what I have to do to get this error.

12