PluginUs.Net - Business Tools for WooCommerce and WordPress

[realize your idea - make your dreams come true]

Support Forum

You need to log-in to create request (topic) to the support

Filter for Pages

The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.
If you not got email within 24~36 business hours, firstly check your spam box, and if no any email from the support there - back to the forum and read answer here. DO NOT ANSWER ON EMAILS [noreply@pluginus.net] FROM THE FORUM!! Emails are just for your info, all answers should be published only here.
The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.

I want to filter by Pages but whatever I put in the type filter it only displays Posts. Am I missing something?

Thanks

Hello

Plugin has no filter by post type.

You can switch which type of post to display - https://c2n.me/4esFZ67.png

Please  watch a  video - https://bulk-editor.pro/video#video_1291

Hi

Thanks for the quick reply.

I meant I want to switch the type of post to display.

The dropdown box referred to in your image defaults to"posts" and all the items displayed are"posts" as expected. From the dropdown  I can select from"page","attachment" and a number of custom post types. If I select"page" (or any of the other options) I get the"Loading..." message at the top of the screen but then it displays only"posts". I cannot get it to display"pages" or any of the custom post types.

I attach a screenshot.

Thanks again for your help.

Screenshot

what plugin version number are you using?

Version 1.0.3.2

Hello

Please  disable  all cache  and  do  a test

If  no  luck:

Try  in  file  - \wp-content\plugins\bulk-editor\lib\storage.php - add  code - https://c2n.me/4etjoA9.png

$this->type = 'session';

If  no  luck:

Please  create  a video  with  the  issue

Hi again,

This is what I've tried - all without success:

I have deleted the cache.

Changed $this->type =$type;  to  $this->type = 'session';

I have disabled all other plugins.

I have changed the theme (Blocksy) to the default theme.

I have uninstalled and reinstalled your plugin.

I am using the plugin on a staging site so I also installed it on the live site but the same problem occurs.

I have also tried it using a completely clean browser (no cookies, no cache, no addons) which I use specifically for testing purposes.

I have created a video as requested video where I try to select 'pages' and also one of my custom post types. This is the link:

https://drive.google.com/file/d/1L8cAtxMXkI4x98PyHZf87os5VHaA2iGk/view?usp=sharing

Any further help appreciated.

 

Hello

Please  update  the  plugin   to latest  version and  do  the  test

If  no  luck  - Drop  me  wp-admin access - https://share.stackovergo.com/image/i20210618130558.png ->https://share.stackovergo.com/image/i20210618130637.png

Thanks, I have sent you a temp admin login.

Hello

My  test - https://c2n.me/4euCLC3

Hi

Firstly many thanks for helping me with this. The issue is now fixed but it was a bit of an adventure to get there. I thought I would share this with you in case it helps in the future.

I saw your screen video and could see that the plugin was behaving correctly. You suggested it was a conflict with a caching plugin. However when I logged into my admin account and tried it myself with the caching plugin deactivated I was experiencing the same old problem. I then logged in using the temporary admin credentials I had sent to you and it worked! So I went back to my own admin account and again it wasn't working.

I then viewed the debug log which showed the following errors when I was logged into my admin account:

[30-Dec-2021 11:13:53 UTC] PHP Notice: Undefined offset: 0 in /customers/0/e/c/(mydomain)/httpd.www/stg_adf38/wp-content/plugins/bulk-editor/ext/meta/meta.php on line 27

This error was not reported when I logged in using the temporary admin account.

The error in  meta.php relates to this:

if ($role[0] == 'administrator') {
$this->add_tab($this->slug, 'panel', esc_html__('Meta Fields', 'bulk-editor'));
add_action('wpbe_ext_panel_' . $this->slug, array($this, 'wpbe_ext_panel'), 1);
}

This got me looking at the Administrator role capabilities and I noticed a discrepancy between the role capabilities of my admin account and the capabilities assigned to temporary admin account. It appears that in my admin account the following capabilities in"custom capabilities" had not be properly assigned:

Frm change settings
Frm delete entries
Frm delete forms
Frm edit forms
Frm view entries
Frm view forms

I don't know if these are specifically related to your plugin but when I updated the Administrator role your plugin worked perfectly.

So now I am happy!

And thanks again for your support. It is very much appreciated.

 

 

 

Hello

Great! Thank you for your cooperation!

Welcome;)