PluginUs.Net - Business Tools for WooCommerce and WordPress

[realize your idea - make your dreams come true]

Support Forum

You need to log-in to create request (topic) to the support

Cant figure out the excluded terms id

The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.
If you not got email within 24~36 business hours, firstly check your spam box, and if no any email from the support there - back to the forum and read answer here. DO NOT ANSWER ON EMAILS [noreply@pluginus.net] FROM THE FORUM!! Emails are just for your info, all answers should be published only here.
The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.
12

Here is the category with id 8888

https://femmefatale.ecode.gr/product-category/%ce%b1%cf%81%cf%8e%ce%bc%ce%b1%cf%84%ce%b1/

Here is the shortcode in this category

[woof is_ajax=1 autohide=0 taxonomies=product_cat:8888]

Here is the setup in the plugin

<img src="https://db3pap004files.storage.live.com/y4mFawVRMYKx8EvyI0igjl9yYIYbZKyc-A0eDjLFkCLCbT-O9EwlbEE2KO7KyyM9jChZpKqkoyfytBbz_TJhKX_9_4SM5wQsj96oR2NJRRDmS71wLBADwlaZPIovkqbVMAeadXcKk-qFqJu5JksgOcOMQQTRJbnI2xFRnHyVwtf5c-So-DVH3MnSyq8F3lQoNV9?width=1097&height=733&cropmode=none" width="1097" height="733" />

 

 

 

Yet, the filter that has been setup for 8888 does not show, whereas the other filters do show.

I will be grateful for your help.

PS. I have a license of the plugin but I couldnt figure out where is the private area to post it.

 

Hello

Please  watch  videos - https://products-filter.com/video#beGT6p_look AND https://products-filter.com/video#kmrp4dAsrrw

why did you put the category ID in the brand field? - https://c2n.me/4ewBSij.png  - this is the field for the current taxonomy ID (in this case the id of the brand attribute)

Please describe in more detail which filter you want to configure

You are unbelievable Pablo! Well done mate!

To be honest I didnt know that by making these selections in options it will show only the active attributes per category and also only the active/valid values of these attributes.

I have one thing for you though. I have selected to show the name of the filter, and during load time, it shows all the titles, (until it hides those that are irrelevant). See for example here:
https://femmefatale.ecode.gr/product-category/%ce%bc%ce%b1%ce%bb%ce%bb%ce%b9%ce%ac-%ce%b5%ce%af%ce%b4%ce%b7-%ce%ba%ce%bf%ce%bc%ce%bc%cf%89%cf%84%ce%b7%cf%81%ce%af%ce%bf%cf%85/%ce%b2%ce%b1%cf%86%ce%ad%cf%82-%cf%87%cf%81%cf%89%ce%bc%ce%bf%ce%bb%ce%bf%cf%83%ce%b9%cf%8c%ce%bd/?min_price=0&max_price=42

You will see some titles appearing, then it realises that this attributes are irrelevant to the category and then it hides them.

Can you please sort  this out? Among the magic that you have done, this should be a trivial task for you :)

edit: In each filter title it adds the word"Product" how can I disable it?

Also, everytime I make a change in the woof structure, options, do I have to rebuild the file datafile?

Last but not least I would like to have for all choices a global css (i.e. when selected for the checkbox selection to be pink). Can I do this so that I can avoid defining in each of the approximately 90 attibutes?

I am glad that I supported you buying your bundle. Keep up the good work!

 

 

 

 

 

Pablo hello again,

I experimented with numerous configurations but still, due to the number of the attributes in the filter it takes a lot of time to"hide" the attributes/selections that are not valid for any given category.

So I think that the most appropriate manner is to use groups of attributes per category (I have the plugin from welaunch) and then just specify in each category for the filter to only seek for these particular attributes, thus avoiding loading/computing each and everyone on demand.

You can see how it behaves with turbo mode enabled here:
https://femmefatale.ecode.gr/product-category/%ce%b1%cf%81%cf%8e%ce%bc%ce%b1%cf%84%ce%b1/%ce%b5%cf%80%cf%8e%ce%bd%cf%85%ce%bc%ce%b1-%ce%b1%cf%81%cf%8e%ce%bc%ce%b1%cf%84%ce%b1/

With the turbo mode it also displays the options for each attribute (before it hides them). In the previous settings, it was just displaying the name of the filter.

 

Hello

then it realises that this attributes are irrelevant to the category and then it hides them.  - this is the recalculation of data for the current request. Please disable  Turbo mode.

edit: In each filter title it adds the word"Product" how can I disable it? - Read this please – https://wordpress.org/support/topic/woocommerce-3-0-prepending-product-to-filters/

do I have to rebuild the file datafile? - if you change product data

 I would like to have for all choices a global css - Please describe it in more detail.

I disabled the turbo mode and works much better.

The issue with the titles (of the irrelevant attributes) appearing still remains.

Here is a short video I wrote for you to understand what I mean:

So the problem is if this can be resolved from your end or if I have to create different includes in each category that will specify explicitly which attributes for the filter to load (this is what I was trying to do initialy, thinking that I can put in the exclude taxonomy field, the caterories where the particular attribute is relevant/irelevant). Please advise.

 

Sorted the prepending issue, thank you!

I have sorted the issue with the css.

 

 

Here is one more explanation about the performance of selecting the relevant attribute groups per product.

Hello

Please  try  to watch  video - https://products-filter.com/video#beGT6p_look

check  options - https://c2n.me/4exsaIs.png

Yes I have checked these options. My only remaining issue is the display of the titles of the attributes that are invalid. They appear for a few seconds until they disappear.

I have watched most of your video. I do not know which part you think can help me solve the issue.

<img src="https://db3pap004files.storage.live.com/y4m216_qV9o4dIslx9-hSH0Gbtq6rNdQvEys43uObID3JEHPeGx0f3UMe0DPSctWR2HG5F8aQMI_S8-w7zNeON1O5zYBzMqujQF7o_An12bVKoKUq-WoCfPWDjj_FHkC4fbonBf56LfI-oBsAK3zoVy7GRbhSZb1AgREmsWtuSbJ91igtxSn9tZH4-IqbWu3oSt?width=1923&height=875&cropmode=none" width="1923" height="875" />

In this image you will find what I mean by defining categories that are relevant to each attribute. It is done on the Product Filters for  Woocommerce filter.

I think you should include it in yours as well. You have done so much good work with optimising speed, caching, etc that it is sad not to have it.

For the moment I bypassed the rendering issue (of the irrelevant terms) by placing the brand as checkboxes, so that it covers the space. The trouble is that although the search is set to OR if I select multiple brands it acts like and AND and as soon as I select the second one... no results are found (because there are no two items having to brands)

As for the rendering, the only issue that remains is the empty box that appears on the screen and then disappears when the price filter renders.
https://femmefatale.ecode.gr/product-category/%ce%b1%cf%81%cf%8e%ce%bc%ce%b1%cf%84%ce%b1/

 

 

To solve the issue with the border appearing and disappearing as well as the shifting of the filter options when the slider appears I added this custom css:

.woof_range_slider {
border:hidden !important;
height: 60px!important;
}

 

Hello

. The trouble is that although the search is set to OR if I select multiple brands it acts like and AND and as soon as I select the second one -  This could be if you are using third party brand building plugins (these third party plugins may override search queries). Please  drop  me  wp-admon  access - https://share.stackovergo.com/image/i20210618130558.png ->https://share.stackovergo.com/image/i20210618130637.png

And describe in more detail what problems remain

Just to let you know that I provided the credentials in the area. Please feel free to see to it.

The only problem that remain is - what I now think - a major feature request: To be able in a future version to define in each attribute for which product categories will be displayed. e.g. so to be able to define that in the category"nails" it will only look for only 10 out of 70"filter by" selections, rather than computing every time for all 70 to realise that only 10 attributes are present in that category. In the previous I provided you with how woocommerce filter is doing it.

 

Just to clarify what I meant:

Say here I pick a brand
https://femmefatale.ecode.gr/product-category/αρώματα/

In the results (filtered view) I would like to be able to see this brand checked, but also to see the checkboxes of all the other options so that I can add a second choice. Right now we have to clear this filter (e.g. go back) and then select another brand. But I can only see one option at a time.

The thing is to avoid this going backwards and to be able to see for as many brands as I choose.

 

 

Hello

The thing is to avoid this going backwards and to be able to see for as many brands as I choose. - Please  do a test.  Are you using the code to change the comparison(search) logic to AND?

To be able in a future version to define in each attribute for which product categories will be displayed. - you can try this third party plugin - https://wordpress.org/plugins/woof-by-category/

 

Here is my response. I hope it makes sense: ;)

And the list keep appearing and the OR.

 

it is for this reason that I asked you this question- https://c2n.me/4ezm8r6.png  - because it looks like a third party script is overriding the search query.

if you haven't customized the code - Did you add this attribute yourself or is it part of the theme / plugin functionality?

Please add FTP access - https://share.stackovergo.com/image/i20210618130558.png ->https://share.stackovergo.com/image/i20210618130637.png

Can I  disable plugins/theme  to  test?

No I haven't customised the code...  The only thing that I changed in your plugin is the icons to pink colour :P  I only experimented with the OR and the AND

Yes you can do anything you please with the site.  (Credentials were provided).

 

 

 

 

 

 

 

Hello

I disabled this  third-party  plugin - https://c2n.me/4eAoOiQ.png - and the search works correctly

Thank you so much Pablo.

12