PluginUs.Net - Business Tools for WooCommerce and WordPress

[realize your idea - make your dreams come true]

Support Forum

You need to log-in to create request (topic) to the support

Cannot redeclare geoip_country_code_by_name_v6

This support system is for all types of the plugins as for premium versions, so for free ones! If you have premium version do not forget in the private data of the request (!!not in the text of the support request!!) after its publishing insert purchase code please (see blue-green button on the right side) and press Save button.
If you not got email within 24~36 business hours, firstly check your spam box, and if no any email from the support there - back to the forum and read answer here. DO NOT ANSWER ON EMAILS [noreply@pluginus.net] FROM THE FORUM!! Emails are just for your info, all answers should be published only here.
The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.

Hello,

When I tried to switch my hosting account from PHP 5.6 to PHP 7.*  I get an error

Fatal error: Cannot redeclare geoip_country_code_by_name_v6() in /home/m/mifcze4c/dvojcata.com/public_html/wp-content/plugins/currency-switcher/lib/geo-ip/geoip.inc on line 1593

Could you please explain me what could be the reason?

Regards
Alexey M.

 

Hello Alexey

It looks like your site has a third-party plugin installed with the same GeoIP library

Try  to  change  file  - wp-content/plugins/currency-switcher/lib/geo-ip/geoip.inc - new  file - https://drive.google.com/open?id=1pdj9tHXE8g0tb5jnPGTsRc8-Mz1kN8BU

 

Hello,

Unfortunately replacing the file didn't help.
I didn't change anything on the site, I just switched the version of the PHP from 5.6 to 7.2.
I attach screenshots
1.jpg - home page of my site with PHP 5.6
2.jpg - home page of my site with PHP 7.2 (with error)

https://drive.google.com/open?id=1B4d_K29XvAodY3ZRuPSQaaNBp3dUqE37

Hello

Try  to   disable  all  plugins(except WPCS).

please activate plugins one at a time to find conflict.

If  no  luck - drop me  wp-admin+FTP  access(Can  I disable plugins? )

Hello,

disabling plugins did not change the situation.
I downloaded the screenshots to the same link.
I gave you access to the site.

And I have turned on PHP 7.2. Please tell me about the situation as soon as possible. If the solution takes time, tell me when can I switch to the PHP 5.6 so that the site works properly.

Hello

Please  add  a link to your  site

Hello,

Sorry)

I have added this information to the top in private data window.

Hello

Please  do  test.

Hello,

Everything is working fine. Thanks!

I just wanted to ask where the corrections were made? Can I update my theme or plugin in the future?

Hello

All  changes in  file - wp-content/plugins/currency-switcher/lib/geo-ip/geoip.inc

We will add these changes to the new version of the plugin.

Thanks!

Hello

Welcome;)