PluginUs.Net - Business Tools for WooCommerce and WordPress

[realize your idea - make your dreams come true]

Support Forum

You need to log-in to create request (topic) to the support

Attributes not all showing up.

This support system is for all types of the plugins as for premium versions, so for free ones! If you have premium version do not forget in the private data of the request (!!not in the text of the support request!!) after its publishing insert purchase code please (see blue-green button on the right side) and press Save button.
If you not got email within 24~36 business hours, firstly check your spam box, and if no any email from the support there - back to the forum and read answer here. DO NOT ANSWER ON EMAILS [noreply@pluginus.net] FROM THE FORUM!! Emails are just for your info, all answers should be published only here.
The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.

Hello,

i have purchased the premium version of BEAR and I went to add my attributes but only one shows up after I hit generate and it is 100% complete in my variable products.

How can we fix this?

 

Actually, the problem is that my variations are adding but in the bulk editor, it is not showing the variation combination so i have to guess at what the combination is to price it.

That's not any better than going in and doing the prices one by one by myself.

 

Hello

Please watch  this vide0 - https://bulk-editor.com/video-tutorials#video_2502  - please watch the full video.at the end of the video there is a description of how to work with variations

I went to add my attributes but only one shows up after I hit generate - Please  drop  me wp-admin access  - https://share.stackovergo.com/image/i20210618130558.png -> https://share.stackovergo.com/image/i20210618130637.png - I will check it

HI Pablo,

i entered that piece of code for now.

It seems to be working. If anything else comes up, I will respond.

Thanks

carla

I'm using the premium version of WOOBE bulk editor.

I get ERROR pop-ups randomly when trying to edit product descriptions.

It works and then stops working.

I reset and start all over again but then I will get an error.

Am i doing something wrong?

 

ill add a temp login for you in the private section.

Also, since you are there, i added descriptions one by one in my smash heart section which looks like it is there when I go to the BEAR description feature but it is not in my actual product page.

this is my product page:

https://carlacookiebox.com/product/smash-hearts-red-heart/

 

This is what I added in the BEAR description section

https://carlacookiebox.com/wp-admin/edit.php?post_type=product&page=woobe#

 

Hello

I checked  it - https://c2n.me/4ddlxsS - Plugin edits data correctly on the product side.  Changes may not be displayed in the front-end due to page caching

I get ERROR pop-ups randomly when trying to edit product descriptions. - https://c2n.me/4ddmfDz.mp4  - I am unable to reproduce this error

Hello....

I cached the page and it is not true because when I go to the product page on the backend it I not saving either. it only saves in the bulk editor

https://snipboard.io/81X4aE.jpg

https://snipboard.io/irBXaN.jpg

Ive cleared my cache several times and nothing changes.

The pop-up error is when I do a bulk save on a bunch of variables.

 

Hello Carla

Text: I just created test product here https://carlacookiebox.com/?post_type=product&p=148448 and tried to change the text in both ways: as trough WOOBE button 'Content' so trough page 'wp-admin/post.php?post=148448&action=edit' - both ways works works

https://clip2net.com/s/4deX4CQ - also I generated variations for this products

Be sure that after generation of 'possible combinations' you press button 'Start BULK Adding!'

Lets work with this product. If we have misunderstanding describe please step by step what you want to get and what you do to get it ...

HI Pablo,

Thank you for getting back to me. :)

The issue is not adding the attributes, it's the texts.

I go to save it and it shows in the WOOBE but not in the actual product page.

Am I doing something wrong? I went to bulk edit (change) the product description for all of the smash products:

https://carlacookiebox.com/product-category/smash-cakes/

but it wouldn't change in the front end. i think i am missing clicking on something to make sure it changes in the front end.

 

I even tried changing my theme and messed up my website, luckily i have backups! lol.

HI Pablo,

I am working with elementor page builder. MAybe it's the page builder not changing the product description. i tried looking up how to fix this but it is not working. Do I have to change all the meta one by one in all of my products?

in that case, I might as well go in one by one and change it so your product wont work for me.

it's frustrating trying to figure this out.  please help.

thank you

 

Hello Carla

I think it is cache can be. After changing texts do not forget to reset site cache. Can you please make short video of what and how you do and what is confusing you just after WOOBE operation done.

I just tried to change text here https://carlacookiebox.com/wp-admin/post.php?post=148448&action=edit - as with Elementor, so with WOOBE it works in both directions ...

Example of screen recorder to make video: https://chrome.google.com/webstore/detail/screen-recorder/hniebljpgcogalllopnjokppmgbhaden?hl=en

 

I must be missing something then...

i have no idea how you did it so I Youtubed it for you...

https://youtu.be/v5VHrBksB54

please let me know what I am doing wrong. it is frustrating to me not to know what I am doing wrong.

Hello Carla

I investigated the issue and found that Elementor keeps data in its own meta fields

I looked the code and created special code to synhronize the data:

add_action('woobe_after_update_page_field', function($product_id, $product, $field_key, $field_value, $field_type) {
if ($field_key === 'post_content') {
$meta_key = '_elementor_data';

$meta = get_post_meta($product_id, $meta_key, true);

if (is_string($meta) && !empty($meta)) {
$meta = json_decode($meta, true);
}

if (empty($meta)) {
$meta = [];
}

foreach ($meta as &$item_lv1) {
if (isset($item_lv1['elements'])) {

foreach ($item_lv1['elements'] as &$item_lv2) {
if (isset($item_lv2['elements'])) {
foreach ($item_lv2['elements'] as &$item_lv3) {
if (isset($item_lv3['settings']['editor'])) {
$item_lv3['settings']['editor']=$field_value;
break(3);
}
}
}
}
}
}

update_post_meta($product_id, $meta_key, $meta);
}
}, 10, 5);

I added the code here: wp-admin/theme-editor.php?file=functions.php&theme=shoptimizer

Now it works, checked here https://carlacookiebox.com/product/smash-hearts-red-heart/ , try it please