PluginUs.Net - Business Tools for WooCommerce and WordPress

[realize your idea - make your dreams come true]

Support Forum

You need to log-in to create request (topic) to the support

All products affected when Bulk Editing / Exporting

This support system is for all types of the plugins as for premium versions, so for free ones! If you have premium version do not forget in the private data of the request (!!not in the text of the support request!!) after its publishing insert purchase code please (see blue-green button on the right side) and press Save button.
If you not got email within 24~36 business hours, firstly check your spam box, and if no any email from the support there - back to the forum and read answer here. DO NOT ANSWER ON EMAILS [noreply@pluginus.net] FROM THE FORUM!! Emails are just for your info, all answers should be published only here.
The support doesn work on Saturdays and Sundays, so some Friday requests can be answered on Monday.

Hi,

We can successfully create a filter that brings back the correct amount of records.
However, when we perform the Bulk Edit or even an Export, all records are affected / exported.

For example, if we filter all Gold Subscription products that renew Monthly, we are presented with 1841 records (out of over 11092).
However, when we try to change the price of these in the Bulk Edit screen, or try to download these records, all 11092 are affected.

Can you please help with this?

Hello

It looks like a conflict with the caching plugin.  please  disable  it  to test

What plugin version number are you using?

Hi Pablo,

Thanks for the reply - we have no caching plugin active, and any caching plugin we use wouldn't be active when logged in.

We are using Version 1.0.8.1 of BEAR - Bulk Editor and Products Manager.

It's not that simple, it is possible with transient caching. And it's worth doing a test without caching plugins

Hi Pablo, I have double-checked and there is no caching present on the website's hosting environment.

Hello

Ok!  Please  create  a test  export.

Compare this file with the file in - wp-content\plugins\woocommerce-bulk-editor\ext\export\__exported_files\

The file in :

wp-content/plugins/woo-bulk-editor/ext/export/__exported_files

Has all 11000 rows, and has not been affected by the filter.

Hello

Ok!  In this  case  try  it, please( https://c2n.me/4cXzIjh.png ) - https://bulk-editor.com/document/more-settings-implicit/

Hi we tried the above and it works.

Is this the definitive solution? Or is there now something we need to do make this work without adding the code to the functions.php file?

Hello

Is this the definitive solution? - Yes.  I recommend that you use a child theme