PluginUs.Net - WooCommerce ve WordPress için İş Araçları

[fikrinizi gerçekleştirin - hayallerinizi gerçekleştirin]

Destek Forumu

Desteğe istek (konu) oluşturmak için oturum açmanız gerekir

Miktar Sepeti Alan Döndürücüsü Doğru Çalışmıyor

Destek Cumartesi ve Pazar günleri çalışmadığından bazı Cuma istekleri Pazartesi günü yanıtlanabilir.
24 ~ 36 iş saati içinde e-posta almadıysanız, öncelikle spam kutunuzu kontrol edin ve oradaki destekten herhangi bir e-posta gelmediyse foruma geri dönün ve cevabı buradan okuyun. YAPMAYIN E-POSTALARDA CEVAP [noreply@pluginus.net] FORUMDAN !! E-postalar sadece bilginiz içindir, tüm cevaplar sadece burada yayınlanmalıdır.
Destek Cumartesi ve Pazar günleri çalışmadığından bazı Cuma istekleri Pazartesi günü yanıtlanabilir.

Nedense, hem WOOT hem de WOOT Upsells tabloları için Sepete Ekle düğmesinin yanındaki miktar kutusu düzgün çalışmıyor. Miktarı artırmaya çalışırsanız hiçbir şey olmaz. Miktarı azaltırsanız, rastgele bir negatif değer elde edersiniz. Koda bakıldığında, tablodaki her satır için Input max değerinin farklı bir negatif sayıya ayarlandığı görülüyor.

Bunu WooCommerce, Elementor ve WOOT dışında tüm eklentiler devre dışıyken test ettim.

Özel alanda bu davranışı gösteren örnek sayfalar sunacağım.

Merhaba

Bu bir stok miktarı sorunudur.

Pozitif değerler kullanabilir misiniz? - https://c2n.me/4fEyznz.png

Ne yazık ki hayır. Ürünlerimizin çoğu siparişe göre üretildiğinden, geri siparişlere izin vermemiz gerekiyor. Üretim sistemi yönetim sürecimizin bir parçası olarak negatif stok miktarları kullanıyoruz.

Merhaba

Anladım! Ancak ne yazık ki eklenti, stoklarımızda bulunandan daha fazla ürün sipariş etmenize izin vermiyor (Stok yönetimi etkinse)

FTP'yi bana atar mısın? - https://share.stackovergo.com/image/i20210618130558.png ->https://share.stackovergo.com/image/i20210618130637.png   düzeltmeye çalışacağım

Üretim sitemize erişim bilgilerini güncelledim ve FTP giriş bilgilerini özel veri kutusuna ekledim.

merhaba

Are you using cache on the server side? because my file changes are not reflected in front end

Yes, we are hosted by Kinsta which uses server caching which cannot be disabled on the production site. It can be cleared in Wordpress by clicking on the Clear Cache option at the top right side of the toolbar.

You can also add specific paths that will not be cached by going to the Kinsta Cache option on the top left menu.

Merhaba

It can be cleared in Wordpress by clicking on the Clear Cache  - of course I tried it

But it looks like my changes that I made yesterday - took effect. Please  do a test

Right. I forgot to mention that clearing the Kinsta cache can sometimes take a few moments to process. Normally development work would be done on the staging site (which has no caching), but at the moment another developer is doing work and I could not turn on any of the plugins.

I tested your changes and the spinners are working correctly now.

Will you be making this change to your plugin? Or will I need to be sure that I make your change to any future plugin updates?

Merhaba

We will continue to investigate this and fix it in the next version.

Hot fix  - in file - wp-content\plugins\woot-products-tables\profiles\woocommerce\js\woocommerce-cart.js - add  code - https://share.stackovergo.com/image/i20220519071929.png

quantity = 9999;

OK. Thank you for your help and fix for this issue.

 

Hoşgeldiniz;)