PluginUs.Net -WooCommerceとWordPressのビジネスツール

[あなたのアイデアを実現する-あなたの夢を実現させる]

サポートフォーラム

サポートへのリクエスト(トピック)を作成するには、ログインする必要があります

モバイルデバイスでウィジェットを非表示にすると、ボタンが表示され、機能しません。

サポートは土曜日と日曜日には機能しないため、一部の金曜日のリクエストには月曜日に回答できます。
24〜36営業時間以内にメールが届かない場合は、まずスパムボックスをチェックし、サポートからのメールがない場合は、フォーラムに戻ってここで回答を読んでください。 しない] メールでの回答[noreply@pluginus.net]フォーラムから!! メールはあなたの情報のためだけのものであり、すべての回答はここでのみ公開する必要があります。
サポートは土曜日と日曜日には機能しないため、一部の金曜日のリクエストには月曜日に回答できます。

こんにちは、

WOOF - WooCommerce Products Filter - v.2.2.6.4
I can't get this option to work:
Hide the widget on a mobile device and a button appears to display the filter.
Appearance > Widgets : mobile mode = Yes
I also tried on no.
I always have the same behavior of the filter in mobile or computer.
I tried the option:
Woocommerce > Product Filter > Design > Hide Default Auto Filter = Yes
I do have an icon on computer and mobile.
I would like the behavior to be different between a mobile and a computer:
- Computer = open
- Mobile = hidden and a button to open it
Since the website is in production, for now I've hidden the mobile filters in css.
I also tried disabling my WP Rocket cache plugin.

別の質問があります
When I add a title to my widgets, it does not appear.
So I added my title in css with the"::before" pseudo class and the content attribute.
I don't really like my solution.
別の解決策はありますか?

真心を込めて

こんにちは

ここにライセンスキーを貼り付けてください- https://share.stackovergo.com/image/i20210618130558.png -> https://share.stackovergo.com/image/i20210618130614.png およびwp-adminアクセス- https://share.stackovergo.com/image/i20210618130637.png - 私はそれをチェックします

こんにちは、

I updated the private part

真心を込めて

こんにちは

Please  delete  all your customization.

Watch this  video - https://products-filter.com/es/video#beGT6p_look

Please note that this is not a sidebar widget - https://share.stackovergo.com/image/i20220520090620.png  You just don't have the sidebar, naturally you don't display a widget and for that reason your widget settings don't apply because there is no widget on the page.

https://share.stackovergo.com/image/i20220520091244.png - This is your customization to display the filter that should be displayed at the top of the products (better remove it - https://share.stackovergo.com/image/i20220520091342.png ) and try setting the template to display the sidebar with widgets

こんにちは、
Indeed, I was not using the sidebar.
However when I activate the Woof Product Filter extension, the sidebar (left or right) goes below the content.
See the capture link in the private content: extension active.
If I disable the Woof Product Filter extension and add a widget, the widget appears in the correct place.
See the capture link in the private content: extension disabled.
I analyzed the HTML code, there are two div tag closures that occur before the aside tag that should be after.
See the HTML code link in the private content: when the Woof Product Filter extension is active.
Since the site is in production, at the moment the sidebar is not active.
どうもありがとう

こんにちは

Ok!  Are you making this theme yourself?  - In this case, check that the standards of the product display template are respected. Use hooks -  woocommerce_before_shop_loop  AND  woocommerce_after_shop_loop

If no - Better  try  another  theme  or  disable  Ajax  mode

 

こんにちは、

It is indeed the Ajax mode that breaks the sidebar layout with the Enfold theme.
So if I disable Ajax mode the layout is fine.

However if I activate in the Widjet the mobile mode on yes.
The icon appears well in mobile but it is not clickable.
There is no JS or Jquery error in the console. Moreover in the html code, there is only a div tag and an image tag.

To work around this problem I did:
1.
Appearance > Widget > Mobile mode > No
2.
Woocommerce > Settings > Product Filter > Options > Yes, but only for mobile devices.
Woocommerce > Settings > Product Filter > Design > Hide Default AutoFilter > Yes.

Is this the correct method?
Is the filter not charging twice?

Tanks you very much,

こんにちは

問題への正確なリンクを私にドロップしてください

This behavior can happen if the theme hides the sidebar for mobile devices

こんにちは、

Indeed, the Enfold theme allows you to hide the sidebar on mobile.

I still have additional questions.
In hide the widget on a mobile device and a button appears to display the filter.
The detection is done with the device but not by the width of the screen, is that right?
If so, I have a problem with this for mobiles (tablets in landscape mode) larger than 990px because the theme works in screen width.
So, I set up CSS for screens from 990px, it seems to me to be using CSS classes that are only valid for"mobiles".
Which seems to me to correct the display.
CSS:
.woof_show_mobile_filter {display:none!important;}
.woof_hide_filter {display:block!important;}

Is this the correct solution?

You can see on any category like:
https://www.marandel-motoculture-pamiers.fr/categorie-produit/tondre/

どうも有難う。

こんにちは

The detection is done with the device but not by the width of the screen, is that right? - 正しい!

Is this the correct solution? - In your case, this is a great solution.

 

こんにちは、

お手伝いいただきありがとうございます。

To resume for readers:
とともに Theme enfold and the widget.
Be careful with :
- Ajax mode
- Sidebar options and add custom css in theme.
- Layout for tablets in landscape mode.

You can close the ticket,

どうもありがとうございました。

こんにちは

すごい! ようこそ;)

ご協力ありがとうございます!