PluginUs.Net - Forretningsværktøjer til WooCommerce og WordPress

[realiser din idé - gør dine drømme til virkelighed]

Support Forum

Du skal logge ind for at oprette anmodning (emne) til supporten

Søgning efter titel virker ikke efter hensigten

Dette supportsystem er til alle typer plugins som til premiumversioner, så gratis! Hvis du har en premiumversion, skal du ikke glemme de private data i anmodningen (!! ikke i teksten i supportanmodningen !!) efter udgivelsen, indsæt købskoden, bedes du se (se den blågrønne knap til højre) og tryk på Gem knap.
Hvis du ikke har fået e-mail inden for 24 ~ 36 åbningstider, skal du først kontrollere dit spam-felt, og hvis der ikke er nogen e-mail fra supporten der - tilbage til forummet og læs svaret her. MÅ IKKE SVAR PÅ E-Mails [noreply@pluginus.net] FRA FORUM !! E-mails er kun til din info, alle svar skal kun offentliggøres her.
Support fungerer ikke lørdage og søndage, så nogle fredagsanmodninger kan besvares mandag.

Hello!

Jeg støder på nogle problemer med søgefunktionen, da den af ​​en eller anden grund ikke finder nogle indlæg.

Søgefunktionen virker til både engelsk og græsk sprog, men det ser ud til, at den af ​​en eller anden grund ikke finder det samme indlæg, hvis jeg bruger forskellige ord i dens titel.

Jeg kan ikke forklare det ordentligt, så jeg vedhæfter nogle billeder, der viser, hvad der er problemet:

1. Hvilket indlæg vil jeg søge efter:

Hvad jeg vil

2. Fungerer på engelsk:

Virker engelsk

3. Fungerer græsk:

Fungerer græsk

4. Virker ikke....:

Virker ikke

 

Som du kan se på billederne ovenfor, søger jeg altid efter posten vist på det første billede. Men tilsyneladende viser søgningen "Ingen data", når nogen søger med et ord til stede i indlægstitlen. Jeg har også prøvet at tilføje søgning efter post_content og post_excerpt, men det virker stadig ikke. Derudover, hvis jeg søger med "EUROLIFE Min investering" virker det stadig ikke, men finder det, hvis jeg bruger "EUROLIFE" eller "Min investering".

Ser frem til dit svar.

Hej

Send mig nøjagtigt link til problemet

Tak for det hurtige svar!

Tilføjet til private data.

Hej

Min test - https://c2n.me/4dUJdC7.png - det ser ud til, at søgningen virker

Hmmm, jeg har lige fundet ud af hvorfor, men kan stadig ikke finde ud af hvorfor..

Hvis jeg copy paste ordet fra indlæggets titel, virker det. Men hvis jeg skriver ordet ved at bruge det græske standardtastatur, virker det ikke.

Jeg tror, ​​det skal være et kodningsproblem.

Prøv at kopiere og indsætte dette: Επενδυτικού

Det lykkedes mig at rette dette nu, da jeg prøvede nogle tests med titlen. Det ser ud til, at indlægget på en eller anden måde blev skrevet forkert.

Men hvorfor kan jeg ikke søge på "EUROLIFE Επενδυτικού" uden at bruge tags, kategorier?

Kan jeg også på en eller anden måde ændre tekstkodningen før initialisering af søgningen til UTF-8, ANSI osv..?

Men hvorfor kan jeg ikke søge på "EUROLIFE Επενδυτικού" uden at bruge tags, kategorier? - Fordi tekstsøgning ikke virker med taksonomier

 kan jeg på en eller anden måde ændre tekstkodningen før initialisering af søgningen til UTF-8, ANSI osv..? - Dette er dine serverindstillinger. Og det skal være UTF-8

Men EUROLIFE er også til stede i posttitlen. Det er ikke kun en kategori/taksonomi.

Mit problem er, at søgningen kun virker, hvis jeg søger på et eller flere bestemte ord ved siden af ​​det ord, jeg søger.

For eksempel:"EUROLIFE FFH ΕΓΚΥΚΛΙΟΣ Υλικά Marketing & Επικοινωνίας του ΕπενδυτικοσλικοσΑικοσΑικοσΑικοσ Επενδυτικοσδυτικορ

Hvis jeg søger efter:

EUROLIFE FFH ΕΓΚΥΚΛΙΟΣ, det virker

Min investeringsplan, den virker

Υλικά Marketing, det virker

MEN

EUROLIFE Υλικά, virker ikke

Επενδυτικού Min investering, virker ikke

osv. osv..

Hej

Ja, for ordene skal stå i samme rækkefølge som i titlen

Hvis du har brug for et avanceret filter - https://wordpress.org/plugins/woocommerce-products-filter/

 

Men jeg bruger ikke woocommerce, vil denne søgning kun fungere med indlæg?

Undskyld du har ret.

I dette tilfælde - https://wordpress.org/plugins/wp-meta-data-filter-and-taxonomy-filter/